summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@haypocalc.com>2011-11-26 23:19:53 (GMT)
committerVictor Stinner <victor.stinner@haypocalc.com>2011-11-26 23:19:53 (GMT)
commit756c6ecdc4fa89efc8f0bb4c048ec4644b8fb5f9 (patch)
treeffce71d02ba3cfe772735439afc72d254cc1ae8e /setup.py
parent5604ef3e36756e59d3396ed16d7a94de2687e0ac (diff)
downloadcpython-756c6ecdc4fa89efc8f0bb4c048ec4644b8fb5f9.zip
cpython-756c6ecdc4fa89efc8f0bb4c048ec4644b8fb5f9.tar.gz
cpython-756c6ecdc4fa89efc8f0bb4c048ec4644b8fb5f9.tar.bz2
Issue #13415: Help to locate curses.h when _curses module is linked to ncursesw
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 97a92ba..1e450c7 100644
--- a/setup.py
+++ b/setup.py
@@ -1173,13 +1173,16 @@ class PyBuildExt(build_ext):
# Curses support, requiring the System V version of curses, often
# provided by the ncurses library.
panel_library = 'panel'
+ curses_includes = []
if curses_library.startswith('ncurses'):
if curses_library == 'ncursesw':
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
panel_library = 'panelw'
+ curses_includes = ['/usr/include/ncursesw']
curses_libs = [curses_library]
exts.append( Extension('_curses', ['_cursesmodule.c'],
+ include_dirs=curses_includes,
define_macros=curses_defines,
libraries = curses_libs) )
elif curses_library == 'curses' and platform != 'darwin':
@@ -1202,6 +1205,7 @@ class PyBuildExt(build_ext):
if (module_enabled(exts, '_curses') and
self.compiler.find_library_file(lib_dirs, panel_library)):
exts.append( Extension('_curses_panel', ['_curses_panel.c'],
+ include_dirs=curses_includes,
libraries = [panel_library] + curses_libs) )
else:
missing.append('_curses_panel')