summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandre Vassalotti <alexandre@peadrop.com>2008-05-06 19:48:38 (GMT)
committerAlexandre Vassalotti <alexandre@peadrop.com>2008-05-06 19:48:38 (GMT)
commit77250f4df7a73a5c87d12d781a562747a855cd95 (patch)
tree61f83259cd270f6011c75cbe95d2a25d12c29f87 /setup.py
parent5d8da20dd1034081906dbdffea9c77bf39353dec (diff)
downloadcpython-77250f4df7a73a5c87d12d781a562747a855cd95.zip
cpython-77250f4df7a73a5c87d12d781a562747a855cd95.tar.gz
cpython-77250f4df7a73a5c87d12d781a562747a855cd95.tar.bz2
Added fast alternate io.BytesIO implementation and its test suite.
Removed old test suite for StringIO. Modified truncate() to imply a seek to given argument value.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 397c392..ab1ad99 100644
--- a/setup.py
+++ b/setup.py
@@ -426,6 +426,8 @@ class PyBuildExt(build_ext):
exts.append( Extension('operator', ['operator.c']) )
# _functools
exts.append( Extension("_functools", ["_functoolsmodule.c"]) )
+ # Memory-based IO accelerator modules
+ exts.append( Extension("_bytesio", ["_bytesio.c"]) )
# atexit
exts.append( Extension("atexit", ["atexitmodule.c"]) )
# Python C API test module