summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2003-12-02 23:01:43 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2003-12-02 23:01:43 (GMT)
commit7d0a609e6f43b82f3aeeefcb0574f3c1e4b09ad4 (patch)
tree61c5b06d9c0ae14ef1b7f9062e7f3b2c483ff315 /setup.py
parent148eb6a6b663df6f949b9eebc1f2b2a97ac11e5c (diff)
downloadcpython-7d0a609e6f43b82f3aeeefcb0574f3c1e4b09ad4.zip
cpython-7d0a609e6f43b82f3aeeefcb0574f3c1e4b09ad4.tar.gz
cpython-7d0a609e6f43b82f3aeeefcb0574f3c1e4b09ad4.tar.bz2
An interface to the LaunchServices API.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 43c2c28..8c75ddc 100644
--- a/setup.py
+++ b/setup.py
@@ -828,6 +828,8 @@ class PyBuildExt(build_ext):
extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_IBCarbon', ['ibcarbon/_IBCarbon.c'],
extra_link_args=['-framework', 'Carbon']) )
+ exts.append( Extension('_Launch', ['launch/_Launchmodule.c'],
+ extra_link_args=['-framework', 'ApplicationServices']) )
exts.append( Extension('_List', ['list/_Listmodule.c'],
extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_Menu', ['menu/_Menumodule.c'],