summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2004-07-15 19:56:25 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2004-07-15 19:56:25 (GMT)
commit84b744775206eceefc9c94ba3e23f18332ac062b (patch)
tree71961e8250cff6d2470185c64d2e1c96cb6f62e8 /setup.py
parent5336f8caa4ed6d3777183f8b0ab1fc81db3eec3d (diff)
downloadcpython-84b744775206eceefc9c94ba3e23f18332ac062b.zip
cpython-84b744775206eceefc9c94ba3e23f18332ac062b.tar.gz
cpython-84b744775206eceefc9c94ba3e23f18332ac062b.tar.bz2
_localemodule now needs to be linked with CoreFoundation on darwin.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bdaa091..5696ee8 100644
--- a/setup.py
+++ b/setup.py
@@ -341,8 +341,15 @@ class PyBuildExt(build_ext):
locale_libs = ['intl']
else:
locale_libs = []
+ if platform == 'darwin':
+ locale_extra_link_args = ['-framework', 'CoreFoundation']
+ else:
+ locale_extra_link_args = []
+
+
exts.append( Extension('_locale', ['_localemodule.c'],
- libraries=locale_libs ) )
+ libraries=locale_libs,
+ extra_link_args=locale_extra_link_args) )
# Modules with some UNIX dependencies -- on by default:
# (If you have a really backward UNIX, select and socket may not be