summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBarry Warsaw <barry@python.org>2011-04-07 14:40:36 (GMT)
committerBarry Warsaw <barry@python.org>2011-04-07 14:40:36 (GMT)
commit88e194513e60853f7074d8f0fbca75d987a7a124 (patch)
treed7e809e130eef35e1f4641e4533aa52e7d9ee826 /setup.py
parent5ca305a599d487beba642903914f0a55259f9d52 (diff)
downloadcpython-88e194513e60853f7074d8f0fbca75d987a7a124.zip
cpython-88e194513e60853f7074d8f0fbca75d987a7a124.tar.gz
cpython-88e194513e60853f7074d8f0fbca75d987a7a124.tar.bz2
Refinement by Stefan Krah (see issue 11715, msg133194) to exit early if the
dpkg-architecture command is not found on $PATH. This should fix the failures on FreeBSD and Solaris, which do not create the target file via I/O redirection if the command isn't found (unlike Linux and OS X which do).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 29a002f..1e15b7a 100644
--- a/setup.py
+++ b/setup.py
@@ -342,6 +342,8 @@ class PyBuildExt(build_ext):
def add_multiarch_paths(self):
# Debian/Ubuntu multiarch support.
# https://wiki.ubuntu.com/MultiarchSpec
+ if not find_executable('dpkg-architecture'):
+ return
tmpfile = os.path.join(self.build_temp, 'multiarch')
if not os.path.exists(self.build_temp):
os.makedirs(self.build_temp)