diff options
author | Ned Deily <nad@python.org> | 2020-05-18 15:31:21 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-05-18 15:31:21 (GMT) |
commit | 951ab58024de9b5a21f0b979cdbea51e1049d781 (patch) | |
tree | 1ea404d9518f6db5d8c1f16435366a8c1716b365 /setup.py | |
parent | adc72bb2f9a5d8b548ee04405e19a184e5699e8d (diff) | |
download | cpython-951ab58024de9b5a21f0b979cdbea51e1049d781.zip cpython-951ab58024de9b5a21f0b979cdbea51e1049d781.tar.gz cpython-951ab58024de9b5a21f0b979cdbea51e1049d781.tar.bz2 |
Revert "bpo-26317: Support OBJC and OBJCXX configure command line variables (GH-20176)" (GH-20182)
This reverts commit 0da546665075aefbb476e192ed64122d340164f4.
The commit is causing make failures on a FreeBSD buildbot.
Due to the imminent 3.9.0b1 cutoff, revert this commit for
now pending further investigation.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 2 insertions, 3 deletions
@@ -1583,11 +1583,10 @@ class PyBuildExt(build_ext): self.missing.append('ossaudiodev') if MACOS: - self.add(Extension('_scproxy', [], + self.add(Extension('_scproxy', ['_scproxy.c'], extra_link_args=[ '-framework', 'SystemConfiguration', - '-framework', 'CoreFoundation'], - extra_objects=['Modules/_scproxy.o'])) + '-framework', 'CoreFoundation'])) def detect_compress_exts(self): # Andrew Kuchling's zlib module. Note that some versions of zlib |