summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorNed Deily <nad@python.org>2020-05-18 15:31:21 (GMT)
committerGitHub <noreply@github.com>2020-05-18 15:31:21 (GMT)
commit951ab58024de9b5a21f0b979cdbea51e1049d781 (patch)
tree1ea404d9518f6db5d8c1f16435366a8c1716b365 /setup.py
parentadc72bb2f9a5d8b548ee04405e19a184e5699e8d (diff)
downloadcpython-951ab58024de9b5a21f0b979cdbea51e1049d781.zip
cpython-951ab58024de9b5a21f0b979cdbea51e1049d781.tar.gz
cpython-951ab58024de9b5a21f0b979cdbea51e1049d781.tar.bz2
Revert "bpo-26317: Support OBJC and OBJCXX configure command line variables (GH-20176)" (GH-20182)
This reverts commit 0da546665075aefbb476e192ed64122d340164f4. The commit is causing make failures on a FreeBSD buildbot. Due to the imminent 3.9.0b1 cutoff, revert this commit for now pending further investigation.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 9b2cc7a..a220f366 100644
--- a/setup.py
+++ b/setup.py
@@ -1583,11 +1583,10 @@ class PyBuildExt(build_ext):
self.missing.append('ossaudiodev')
if MACOS:
- self.add(Extension('_scproxy', [],
+ self.add(Extension('_scproxy', ['_scproxy.c'],
extra_link_args=[
'-framework', 'SystemConfiguration',
- '-framework', 'CoreFoundation'],
- extra_objects=['Modules/_scproxy.o']))
+ '-framework', 'CoreFoundation']))
def detect_compress_exts(self):
# Andrew Kuchling's zlib module. Note that some versions of zlib