diff options
author | Gregory P. Smith <greg@mad-scientist.com> | 2007-09-10 16:38:12 (GMT) |
---|---|---|
committer | Gregory P. Smith <greg@mad-scientist.com> | 2007-09-10 16:38:12 (GMT) |
commit | 954c31bcc737c99b597870b42611228ed05ac699 (patch) | |
tree | edfed80e4b76a2c8599d79ecddf9f00a34bbd005 /setup.py | |
parent | da86fcc803dce9983914f36c8bb3a76176953580 (diff) | |
download | cpython-954c31bcc737c99b597870b42611228ed05ac699.zip cpython-954c31bcc737c99b597870b42611228ed05ac699.tar.gz cpython-954c31bcc737c99b597870b42611228ed05ac699.tar.bz2 |
merge of r58091 from trunk:
Don't allow BerkeleyDB 4.6.x as the current 4.6.19 release is prone
to lockups. We'll reenable it once a good 4.6.x release exists.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 4 insertions, 2 deletions
@@ -637,7 +637,9 @@ class PyBuildExt(build_ext): # a release. Most open source OSes come with one or more # versions of BerkeleyDB already installed. - max_db_ver = (4, 6) + # XXX(gps) - Do not allow BerkeleyDB 4.6.x until Oracle fixes + # the DB_HASH lockup bug that is present in 4.6.19. + max_db_ver = (4, 5) min_db_ver = (3, 3) db_setup_debug = False # verbose debug prints from this script? @@ -655,7 +657,7 @@ class PyBuildExt(build_ext): '/sw/include/db3', ] # 4.x minor number specific paths - for x in (0,1,2,3,4,5,6): + for x in range(max_db_ver[1]+1): db_inc_paths.append('/usr/include/db4%d' % x) db_inc_paths.append('/usr/include/db4.%d' % x) db_inc_paths.append('/usr/local/BerkeleyDB.4.%d/include' % x) |