summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2002-08-29 21:09:00 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2002-08-29 21:09:00 (GMT)
commit983258ed7e96897e00c7a4459034d83816018181 (patch)
tree31117f49ebc283ef7affa094343af9c32e4b6ecb /setup.py
parentd94c28e467cc550cc09d082eb8bd078e4f2df2e4 (diff)
downloadcpython-983258ed7e96897e00c7a4459034d83816018181.zip
cpython-983258ed7e96897e00c7a4459034d83816018181.tar.gz
cpython-983258ed7e96897e00c7a4459034d83816018181.tar.bz2
Revived the Carbon.Help module, but implementing the MacHelp API in stead
of the defunct Balloons API. Help tags are TBD, but at least this gives us access to the help menu.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index c78ebc9..3341e46 100644
--- a/setup.py
+++ b/setup.py
@@ -778,6 +778,8 @@ class PyBuildExt(build_ext):
extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_AE', ['ae/_AEmodule.c'],
extra_link_args=['-framework', 'Carbon']) )
+ exts.append( Extension('_AH', ['ah/_AHmodule.c'],
+ extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_App', ['app/_Appmodule.c'],
extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_CarbonEvt', ['carbonevt/_CarbonEvtmodule.c'],
@@ -797,6 +799,8 @@ class PyBuildExt(build_ext):
extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_Fm', ['fm/_Fmmodule.c'],
extra_link_args=['-framework', 'Carbon']) )
+ exts.append( Extension('_Help', ['help/_Helpmodule.c'],
+ extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_Icn', ['icn/_Icnmodule.c'],
extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_IBCarbon', ['ibcarbon/_IBCarbon.c'],