diff options
author | Ned Deily <nad@acm.org> | 2012-08-05 22:13:33 (GMT) |
---|---|---|
committer | Ned Deily <nad@acm.org> | 2012-08-05 22:13:33 (GMT) |
commit | 9b635837c5629e07a2a8fd400d06f054d3a8f940 (patch) | |
tree | a2d127b13cde966c189914fff3d7fa5fc9802dc9 /setup.py | |
parent | 9ccf82d8445178780a4270d4965d482b52008f00 (diff) | |
download | cpython-9b635837c5629e07a2a8fd400d06f054d3a8f940.zip cpython-9b635837c5629e07a2a8fd400d06f054d3a8f940.tar.gz cpython-9b635837c5629e07a2a8fd400d06f054d3a8f940.tar.bz2 |
Issue #15560: Fix building _sqlite3 extension on OS X with an SDK.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -1041,12 +1041,12 @@ class PyBuildExt(build_ext): if host_platform == 'darwin': sysroot = macosx_sdk_root() - for d in inc_dirs + sqlite_inc_paths: - f = os.path.join(d, "sqlite3.h") - + for d_ in inc_dirs + sqlite_inc_paths: + d = d_ if host_platform == 'darwin' and is_macosx_sdk_path(d): - f = os.path.join(sysroot, d[1:], "sqlite3.h") + d = os.path.join(sysroot, d[1:]) + f = os.path.join(d, "sqlite3.h") if os.path.exists(f): if sqlite_setup_debug: print("sqlite: found %s"%f) with open(f) as file: |