summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2012-08-05 22:13:33 (GMT)
committerNed Deily <nad@acm.org>2012-08-05 22:13:33 (GMT)
commit9b635837c5629e07a2a8fd400d06f054d3a8f940 (patch)
treea2d127b13cde966c189914fff3d7fa5fc9802dc9 /setup.py
parent9ccf82d8445178780a4270d4965d482b52008f00 (diff)
downloadcpython-9b635837c5629e07a2a8fd400d06f054d3a8f940.zip
cpython-9b635837c5629e07a2a8fd400d06f054d3a8f940.tar.gz
cpython-9b635837c5629e07a2a8fd400d06f054d3a8f940.tar.bz2
Issue #15560: Fix building _sqlite3 extension on OS X with an SDK.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index d419d48..bc1e1bb 100644
--- a/setup.py
+++ b/setup.py
@@ -1041,12 +1041,12 @@ class PyBuildExt(build_ext):
if host_platform == 'darwin':
sysroot = macosx_sdk_root()
- for d in inc_dirs + sqlite_inc_paths:
- f = os.path.join(d, "sqlite3.h")
-
+ for d_ in inc_dirs + sqlite_inc_paths:
+ d = d_
if host_platform == 'darwin' and is_macosx_sdk_path(d):
- f = os.path.join(sysroot, d[1:], "sqlite3.h")
+ d = os.path.join(sysroot, d[1:])
+ f = os.path.join(d, "sqlite3.h")
if os.path.exists(f):
if sqlite_setup_debug: print("sqlite: found %s"%f)
with open(f) as file: