diff options
author | Neil Schemenauer <nas-github@arctrix.com> | 2017-06-16 02:12:46 (GMT) |
---|---|---|
committer | Mariatta <Mariatta@users.noreply.github.com> | 2017-06-16 02:12:46 (GMT) |
commit | 9cead06076f890d4951b3ea2571408efe76f8b2c (patch) | |
tree | 9f4a816fa83e49a46f35c8c7d968dc8f329f8db2 /setup.py | |
parent | 6a90a124706b73824aebf5c2bd7b27daf82b2342 (diff) | |
download | cpython-9cead06076f890d4951b3ea2571408efe76f8b2c.zip cpython-9cead06076f890d4951b3ea2571408efe76f8b2c.tar.gz cpython-9cead06076f890d4951b3ea2571408efe76f8b2c.tar.bz2 |
Check that Python is 64-bit before enabling BLAKE2_USE_SSE. (GH-1332) (GH-2042)
(cherry picked from commit 6c991bdee7ec4bedd8c1b8d3812dc884b654b57c)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -897,8 +897,11 @@ class PyBuildExt(build_ext): blake2_deps.append('hashlib.h') blake2_macros = [] - if not cross_compiling and os.uname().machine == "x86_64": - # Every x86_64 machine has at least SSE2. + if (not cross_compiling and + os.uname().machine == "x86_64" and + sys.maxsize > 2**32): + # Every x86_64 machine has at least SSE2. Check for sys.maxsize + # in case that kernel is 64-bit but userspace is 32-bit. blake2_macros.append(('BLAKE2_USE_SSE', '1')) exts.append( Extension('_blake2', |