summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew M. Kuchling <amk@amk.ca>2001-07-14 20:28:10 (GMT)
committerAndrew M. Kuchling <amk@amk.ca>2001-07-14 20:28:10 (GMT)
commit9eb27a89d8e37504a685651963c390bf8ebf78ca (patch)
treecdf3690ac999656c98a7f2d670d8462f6902447b /setup.py
parent3c29602d740937cc96318031737dc3f0df59998d (diff)
downloadcpython-9eb27a89d8e37504a685651963c390bf8ebf78ca.zip
cpython-9eb27a89d8e37504a685651963c390bf8ebf78ca.tar.gz
cpython-9eb27a89d8e37504a685651963c390bf8ebf78ca.tar.bz2
Fix bug #437487: "2.1 build on Solaris fails if CC is set"
by adding the contents of CCSHARED to the compiler specified by CC
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5c5f5dc..545143a 100644
--- a/setup.py
+++ b/setup.py
@@ -116,7 +116,8 @@ class PyBuildExt(build_ext):
# unfortunately, distutils doesn't let us provide separate C and C++
# compilers
if compiler is not None:
- args['compiler_so'] = compiler
+ (ccshared,) = sysconfig.get_config_vars('CCSHARED')
+ args['compiler_so'] = compiler + ' ' + ccshared
if linker_so is not None:
args['linker_so'] = linker_so + ' -shared'
self.compiler.set_executables(**args)