diff options
author | Victor Stinner <vstinner@python.org> | 2020-04-17 17:05:35 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-04-17 17:05:35 (GMT) |
commit | 9f5fe7910f4a1bf5a425837d4915e332b945eb7b (patch) | |
tree | 5f652699332e33a81cf6baa5ff5b6fecadea1903 /setup.py | |
parent | 22386bb4ef740ee92d34c87b8cb90d681423a853 (diff) | |
download | cpython-9f5fe7910f4a1bf5a425837d4915e332b945eb7b.zip cpython-9f5fe7910f4a1bf5a425837d4915e332b945eb7b.tar.gz cpython-9f5fe7910f4a1bf5a425837d4915e332b945eb7b.tar.bz2 |
bpo-40286: Add randbytes() method to random.Random (GH-19527)
Add random.randbytes() function and random.Random.randbytes()
method to generate random bytes.
Modify secrets.token_bytes() to use SystemRandom.randbytes()
rather than calling directly os.urandom().
Rename also genrand_int32() to genrand_uint32(), since it returns an
unsigned 32-bit integer, not a signed integer.
The _random module is now built with Py_BUILD_CORE_MODULE defined.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -808,7 +808,8 @@ class PyBuildExt(build_ext): self.add(Extension('_datetime', ['_datetimemodule.c'], libraries=['m'])) # random number generator implemented in C - self.add(Extension("_random", ["_randommodule.c"])) + self.add(Extension("_random", ["_randommodule.c"], + extra_compile_args=['-DPy_BUILD_CORE_MODULE'])) # bisect self.add(Extension("_bisect", ["_bisectmodule.c"])) # heapq |