summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2012-09-01 12:21:22 (GMT)
committerStefan Krah <skrah@bytereef.org>2012-09-01 12:21:22 (GMT)
commita10e2fbe0bb820d2c893653b4e42b10cb7d5eb27 (patch)
tree8e0f5fb5fd74d60ef8385f6a34207e41084cd5a9 /setup.py
parent6f858a2eea0918af92673be6ed784f9fbe94134d (diff)
downloadcpython-a10e2fbe0bb820d2c893653b4e42b10cb7d5eb27.zip
cpython-a10e2fbe0bb820d2c893653b4e42b10cb7d5eb27.tar.gz
cpython-a10e2fbe0bb820d2c893653b4e42b10cb7d5eb27.tar.bz2
Compile _decimal without asserts and update benchmark results.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7f863a4..9ddf2e9 100644
--- a/setup.py
+++ b/setup.py
@@ -1897,7 +1897,7 @@ class PyBuildExt(build_ext):
def _decimal_ext(self):
extra_compile_args = []
- undef_macros = ['NDEBUG']
+ undef_macros = []
if '--with-system-libmpdec' in sysconfig.get_config_var("CONFIG_ARGS"):
include_dirs = []
libraries = ['mpdec']