diff options
author | Christian Heimes <christian@cheimes.de> | 2007-12-04 23:02:19 (GMT) |
---|---|---|
committer | Christian Heimes <christian@cheimes.de> | 2007-12-04 23:02:19 (GMT) |
commit | a37d4c693a024154093b36a612810c3bd72d9254 (patch) | |
tree | d8c061b9356d7bf8f444bcfd7869c1ac5bec9f3c /setup.py | |
parent | 327858ef2c4512937a1333212a3b46a62c18ccc3 (diff) | |
download | cpython-a37d4c693a024154093b36a612810c3bd72d9254.zip cpython-a37d4c693a024154093b36a612810c3bd72d9254.tar.gz cpython-a37d4c693a024154093b36a612810c3bd72d9254.tar.bz2 |
Removed PyInt_GetMax and sys.maxint
I replaced sys.maxint with sys.maxsize in Lib/*.py. Does anybody see a problem with the change on Win 64bit platforms? Win 64's long is just 32bit but the sys.maxsize is now 2**63-1 on every 64bit platform.
Also added docs for sys.maxsize.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -1074,7 +1074,7 @@ class PyBuildExt(build_ext): ['cjkcodecs/_codecs_%s.c' % loc])) # Dynamic loading module - if sys.maxint == 0x7fffffff: + if sys.maxsize == 0x7fffffff: # This requires sizeof(int) == sizeof(long) == sizeof(char*) dl_inc = find_file('dlfcn.h', [], inc_dirs) if (dl_inc is not None) and (platform not in ['atheos']): |