diff options
author | Benjamin Peterson <benjamin@python.org> | 2009-12-31 03:23:10 (GMT) |
---|---|---|
committer | Benjamin Peterson <benjamin@python.org> | 2009-12-31 03:23:10 (GMT) |
commit | b2d90467927e953bd2c195b7d6de94744a13ce60 (patch) | |
tree | 697845b1cb0aa787c6e8db77e98f454222a9be13 /setup.py | |
parent | 587a31001e3bb8c959c9fbd4b2872e4c6179026b (diff) | |
download | cpython-b2d90467927e953bd2c195b7d6de94744a13ce60.zip cpython-b2d90467927e953bd2c195b7d6de94744a13ce60.tar.gz cpython-b2d90467927e953bd2c195b7d6de94744a13ce60.tar.bz2 |
Merged revisions 77169 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk
........
r77169 | benjamin.peterson | 2009-12-30 21:17:18 -0600 (Wed, 30 Dec 2009) | 2 lines
add a --with-system-expat option to build pyexpat against the system's lib #7609
........
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 30 |
1 files changed, 19 insertions, 11 deletions
@@ -1104,19 +1104,26 @@ class PyBuildExt(build_ext): # # More information on Expat can be found at www.libexpat.org. # - expatinc = os.path.join(os.getcwd(), srcdir, 'Modules', 'expat') - define_macros = [ - ('HAVE_EXPAT_CONFIG_H', '1'), - ] + if '--with-system-expat' in sysconfig.get_config_var("CONFIG_ARGS"): + expat_inc = [] + define_macros = [] + expat_lib = ['expat'] + expat_sources = [] + else: + expat_inc = [os.path.join(os.getcwd(), srcdir, 'Modules', 'expat')] + define_macros = [ + ('HAVE_EXPAT_CONFIG_H', '1'), + ] + expat_lib = [] + expat_sources = ['expat/xmlparse.c', + 'expat/xmlrole.c', + 'expat/xmltok.c'] exts.append(Extension('pyexpat', define_macros = define_macros, - include_dirs = [expatinc], - sources = ['pyexpat.c', - 'expat/xmlparse.c', - 'expat/xmlrole.c', - 'expat/xmltok.c', - ], + include_dirs = expat_inc, + libraries = expat_lib, + sources = ['pyexpat.c'] + expat_sources )) # Fredrik Lundh's cElementTree module. Note that this also @@ -1126,7 +1133,8 @@ class PyBuildExt(build_ext): define_macros.append(('USE_PYEXPAT_CAPI', None)) exts.append(Extension('_elementtree', define_macros = define_macros, - include_dirs = [expatinc], + include_dirs = expat_inc, + libraries = expat_lib, sources = ['_elementtree.c'], )) else: |