summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSkip Montanaro <skip@pobox.com>2007-09-06 16:30:31 (GMT)
committerSkip Montanaro <skip@pobox.com>2007-09-06 16:30:31 (GMT)
commitd3f6c9d17b7ccbb1e2a887d871d35c30c36eca1e (patch)
tree02b5f39e04a4df721ddea19c6933b9a452550245 /setup.py
parent22291c500895077509916620a4a55bdae37cc51e (diff)
downloadcpython-d3f6c9d17b7ccbb1e2a887d871d35c30c36eca1e.zip
cpython-d3f6c9d17b7ccbb1e2a887d871d35c30c36eca1e.tar.gz
cpython-d3f6c9d17b7ccbb1e2a887d871d35c30c36eca1e.tar.bz2
I think we can just dump the else clause, per the comment I just deleted.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 0 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 6af41c2..a0a02cb 100644
--- a/setup.py
+++ b/setup.py
@@ -617,9 +617,6 @@ class PyBuildExt(build_ext):
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
exts.append( Extension('_sha512', ['sha512module.c']) )
- else:
- # these aren't strictly missing since they are unneeded.
- missing.extend(['_sha256', '_sha512'])
# Modules that provide persistent dictionary-like semantics. You will
# probably want to arrange for at least one of them to be available on