summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorÉric Araujo <merwok@netwok.org>2011-06-09 12:07:02 (GMT)
committerÉric Araujo <merwok@netwok.org>2011-06-09 12:07:02 (GMT)
commite6792c1e771fab4ed025beeb8f71fb2d5c7d53e8 (patch)
treea16bfcb20c2f6968e52b88dc15dc1b53189083c1 /setup.py
parentc7f9f2bfc7dbe9d26d0cbe159e9e8c2a5efe21d7 (diff)
downloadcpython-e6792c1e771fab4ed025beeb8f71fb2d5c7d53e8.zip
cpython-e6792c1e771fab4ed025beeb8f71fb2d5c7d53e8.tar.gz
cpython-e6792c1e771fab4ed025beeb8f71fb2d5c7d53e8.tar.bz2
Stop creating a Python-X.Y.Z-pyX.Y.egg-info file on install (#10645)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 39751c3..2426aad 100644
--- a/setup.py
+++ b/setup.py
@@ -1780,6 +1780,13 @@ class PyBuildInstall(install):
install.initialize_options(self)
self.warn_dir=0
+ # Customize subcommands to not install an egg-info file for Python
+ sub_commands = [('install_lib', install.has_lib),
+ ('install_headers', install.has_headers),
+ ('install_scripts', install.has_scripts),
+ ('install_data', install.has_data)]
+
+
class PyBuildInstallLib(install_lib):
# Do exactly what install_lib does but make sure correct access modes get
# set on installed directories and files. All installed files with get