diff options
author | Walter Dörwald <walter@livinglogic.de> | 2007-05-22 16:02:13 (GMT) |
---|---|---|
committer | Walter Dörwald <walter@livinglogic.de> | 2007-05-22 16:02:13 (GMT) |
commit | e9eaab448bc88f96a6a28a589577dbfd7035027f (patch) | |
tree | 3f5ddf3b36e93cdc115380e6f1228d090b1f9614 /setup.py | |
parent | d6ca5460914926e54c2a063728a6c785ced8a702 (diff) | |
download | cpython-e9eaab448bc88f96a6a28a589577dbfd7035027f.zip cpython-e9eaab448bc88f96a6a28a589577dbfd7035027f.tar.gz cpython-e9eaab448bc88f96a6a28a589577dbfd7035027f.tar.bz2 |
The unicode builtin is gone now. Fix setup.py so that
unicodedata and the CJK codecs are built again.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 25 |
1 files changed, 6 insertions, 19 deletions
@@ -317,11 +317,6 @@ class PyBuildExt(build_ext): add_dir_to_list(self.compiler.include_dirs, sysconfig.get_config_var("INCLUDEDIR")) - try: - have_unicode = unicode - except NameError: - have_unicode = 0 - # lib_dirs and inc_dirs are used to search for files; # if a file is found in one of those directories, it can # be assumed that no additional -I,-L directives are needed. @@ -418,10 +413,7 @@ class PyBuildExt(build_ext): exts.append( Extension('_hotshot', ['_hotshot.c']) ) exts.append( Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c']) ) # static Unicode character database - if have_unicode: - exts.append( Extension('unicodedata', ['unicodedata.c']) ) - else: - missing.append('unicodedata') + exts.append( Extension('unicodedata', ['unicodedata.c']) ) # access to ISO C locale support data = open('pyconfig.h').read() m = re.search(r"#s*define\s+WITH_LIBINTL\s+1\s*", data) @@ -1082,16 +1074,11 @@ class PyBuildExt(build_ext): missing.append('_elementtree') # Hye-Shik Chang's CJKCodecs modules. - if have_unicode: - exts.append(Extension('_multibytecodec', - ['cjkcodecs/multibytecodec.c'])) - for loc in ('kr', 'jp', 'cn', 'tw', 'hk', 'iso2022'): - exts.append(Extension('_codecs_%s' % loc, - ['cjkcodecs/_codecs_%s.c' % loc])) - else: - missing.append('_multibytecodec') - for loc in ('kr', 'jp', 'cn', 'tw', 'hk', 'iso2022'): - missing.append('_codecs_%s' % loc) + exts.append(Extension('_multibytecodec', + ['cjkcodecs/multibytecodec.c'])) + for loc in ('kr', 'jp', 'cn', 'tw', 'hk', 'iso2022'): + exts.append(Extension('_codecs_%s' % loc, + ['cjkcodecs/_codecs_%s.c' % loc])) # Dynamic loading module if sys.maxint == 0x7fffffff: |