diff options
author | Jack Jansen <jack.jansen@cwi.nl> | 2001-12-09 23:08:54 (GMT) |
---|---|---|
committer | Jack Jansen <jack.jansen@cwi.nl> | 2001-12-09 23:08:54 (GMT) |
commit | edeea04bfd8342c5339cea701d9c6c08186a1cdb (patch) | |
tree | 1920f424b878844752056d408437bae187bcac79 /setup.py | |
parent | 793ead5696dbb7e0897e459aed2cd64cd1e14788 (diff) | |
download | cpython-edeea04bfd8342c5339cea701d9c6c08186a1cdb.zip cpython-edeea04bfd8342c5339cea701d9c6c08186a1cdb.tar.gz cpython-edeea04bfd8342c5339cea701d9c6c08186a1cdb.tar.bz2 |
Mods to make WASTE module compile and link for MachoPython. Not tested
any further, yet.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 20 |
1 files changed, 19 insertions, 1 deletions
@@ -634,7 +634,25 @@ class PyBuildExt(build_ext): ## exts.append( Extension('_Scrap', ['scrap/_Scrapmodule.c']) ) exts.append( Extension('_TE', ['te/_TEmodule.c'], extra_link_args=['-framework', 'Carbon']) ) -## exts.append( Extension('waste', ['waste/wastemodule.c']) ) + # As there is no standardized place (yet) to put user-installed + # Mac libraries on OSX you should put a symlink to your Waste + # installation in the same folder as your python source tree. + # Or modify the next two lines:-) + waste_incs = find_file("WASTE.h", [], ["../waste/C_C++ Headers"]) + waste_libs = find_library_file(self.compiler, "WASTE", [], + ["../waste/Static Libraries"]) + if waste_incs != None and waste_libs != None: + exts.append( Extension('waste', + ['waste/wastemodule.c', + 'Mac/Wastemods/WEObjectHandlers.c', + 'Mac/Wastemods/WETabHooks.c', + 'Mac/Wastemods/WETabs.c' + ], + include_dirs = waste_incs + ['Mac/Wastemods'], + library_dirs = waste_libs, + libraries = ['WASTE'], + extra_link_args = ['-framework', 'Carbon'], + ) ) exts.append( Extension('_Win', ['win/_Winmodule.c'], extra_link_args=['-framework', 'Carbon']) ) |