summaryrefslogtreecommitdiffstats
path: root/Lib/test/test_cext/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'Lib/test/test_cext/setup.py')
-rw-r--r--Lib/test/test_cext/setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/Lib/test/test_cext/setup.py b/Lib/test/test_cext/setup.py
index dd57a5f..aed7e6d 100644
--- a/Lib/test/test_cext/setup.py
+++ b/Lib/test/test_cext/setup.py
@@ -16,6 +16,10 @@ if not support.MS_WINDOWS:
# The purpose of test_cext extension is to check that building a C
# extension using the Python C API does not emit C compiler warnings.
'-Werror',
+
+ # gh-116869: The Python C API must build with
+ # -Werror=declaration-after-statement.
+ '-Werror=declaration-after-statement',
]
else:
# Don't pass any compiler flag to MSVC