summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 36199b3..bc3d2d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5920,7 +5920,12 @@ AX_C_FLOAT_WORDS_BIGENDIAN(
stored in ARM mixed-endian order (byte order 45670123)])],
[wasm*], [AC_DEFINE([DOUBLE_IS_LITTLE_ENDIAN_IEEE754], [1],
[Define if C doubles are 64-bit IEEE 754 binary format,
- stored with the least significant byte first])])])
+ stored with the least significant byte first])],
+ [AC_MSG_ERROR([m4_normalize([
+ Unknown float word ordering. You need to manually
+ preset ax_cv_c_float_words_bigendian=no (or yes)
+ according to your system.
+ ])])])])
# The short float repr introduced in Python 3.1 requires the
# correctly-rounded string <-> double conversion functions from