summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 3 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ee034e5..50b130f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6672,7 +6672,7 @@ then
[Define if year with century should be normalized for strftime.])
fi
-AC_CACHE_CHECK([whether C99-specific strftime specifiers are supported], [ac_cv_strftime_c99_support], [
+AC_CACHE_CHECK([whether C99-compatible strftime specifiers are supported], [ac_cv_strftime_c99_support], [
AC_RUN_IFELSE([AC_LANG_SOURCE([[
#include <time.h>
#include <string.h>
@@ -6692,13 +6692,8 @@ int main(void)
}
]])],
[ac_cv_strftime_c99_support=yes],
-[ac_cv_strftime_c99_support=no],
-[ac_cv_strftime_c99_support=no])])
-if test "$ac_cv_strftime_c99_support" = yes
-then
- AC_DEFINE([Py_STRFTIME_C99_SUPPORT], [1],
- [Define if C99-specific strftime specifiers are supported.])
-fi
+[AC_MSG_ERROR([Python requires C99-compatible strftime specifiers])],
+[ac_cv_strftime_c99_support=])])
dnl check for ncursesw/ncurses and panelw/panel
dnl NOTE: old curses is not detected.