summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 0 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 03dce63..4bef3cb 100644
--- a/setup.py
+++ b/setup.py
@@ -1748,19 +1748,12 @@ class PyBuildExt(build_ext):
#
if '--with-system-expat' in sysconfig.get_config_var("CONFIG_ARGS"):
expat_inc = []
- define_macros = []
extra_compile_args = []
expat_lib = ['expat']
expat_sources = []
expat_depends = []
else:
expat_inc = [os.path.join(self.srcdir, 'Modules', 'expat')]
- define_macros = [
- ('HAVE_EXPAT_CONFIG_H', '1'),
- # bpo-30947: Python uses best available entropy sources to
- # call XML_SetHashSalt(), expat entropy sources are not needed
- ('XML_POOR_ENTROPY', '1'),
- ]
extra_compile_args = []
# bpo-44394: libexpat uses isnan() of math.h and needs linkage
# against the libm
@@ -1788,7 +1781,6 @@ class PyBuildExt(build_ext):
extra_compile_args.append('-Wno-unreachable-code')
self.add(Extension('pyexpat',
- define_macros=define_macros,
extra_compile_args=extra_compile_args,
include_dirs=expat_inc,
libraries=expat_lib,
@@ -1799,9 +1791,7 @@ class PyBuildExt(build_ext):
# uses expat (via the CAPI hook in pyexpat).
if os.path.isfile(os.path.join(self.srcdir, 'Modules', '_elementtree.c')):
- define_macros.append(('USE_PYEXPAT_CAPI', None))
self.add(Extension('_elementtree',
- define_macros=define_macros,
include_dirs=expat_inc,
libraries=expat_lib,
sources=['_elementtree.c'],