summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-04-25 04:42:30 (GMT)
committerzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-04-25 04:42:30 (GMT)
commitf2334aa19555063791ec16fe2b476ec00195bbb8 (patch)
treec5479b63622d0a54a1838a0aa735021723017612 /configure.ac
parentfa2b06c52fa3ffb1909ed8b928e106292609cfcb (diff)
downloadgoogletest-f2334aa19555063791ec16fe2b476ec00195bbb8.zip
googletest-f2334aa19555063791ec16fe2b476ec00195bbb8.tar.gz
googletest-f2334aa19555063791ec16fe2b476ec00195bbb8.tar.bz2
Ports gtest to minGW (by Kenton Varda).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac6d51d..92670bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,3 +1,5 @@
+m4_include(m4/acx_pthread.m4)
+
# At this point, the Xcode project assumes the version string will be three
# integers separated by periods and surrounded by square brackets (e.g.
# "[1.0.1]"). It also asumes that there won't be any closing parenthesis
@@ -37,6 +39,9 @@ AS_IF([test "$PYTHON" != ":"],
[AM_PYTHON_CHECK_VERSION([$PYTHON],[2.3],[:],[PYTHON=":"])])
AM_CONDITIONAL([HAVE_PYTHON],[test "$PYTHON" != ":"])
+# Check for pthreads.
+ACX_PTHREAD
+
# TODO(chandlerc@google.com) Check for the necessary system headers.
# TODO(chandlerc@google.com) Check the types, structures, and other compiler