summaryrefslogtreecommitdiffstats
path: root/googlemock/CMakeLists.txt
diff options
context:
space:
mode:
authorEnji Cooper <yaneurabeya@gmail.com>2019-03-04 20:40:12 (GMT)
committerEnji Cooper <yaneurabeya@gmail.com>2019-03-29 22:00:05 (GMT)
commit9b6de41b5d9d7b78c4dfdc5e64df4323f677c69c (patch)
tree03e4a4358bb2c24b0b773f1d8b127d9f32080732 /googlemock/CMakeLists.txt
parent5b752b1947bbb4df571848a1afad00f9b06f30e0 (diff)
downloadgoogletest-9b6de41b5d9d7b78c4dfdc5e64df4323f677c69c.zip
googletest-9b6de41b5d9d7b78c4dfdc5e64df4323f677c69c.tar.gz
googletest-9b6de41b5d9d7b78c4dfdc5e64df4323f677c69c.tar.bz2
Prefix googletest binaries under its own subtree instead of `gtest`refs/pull/2163/head
Building all test binaries under their respective subtrees makes building the project via cmake easier to grok without additional hacks. In particular, when dealing with the conversion I proposed in https://reviews.freebsd.org/D19430 (switching from autotools to cmake), I ran into unexpected gtest prefixing under the googlemock directory, as opposed to the googletest directory. Example: Before: `googlemock/gtest/googletest-break-on-failure-unittest_` After: `googletest/googletest-break-on-failure-unittest_` The latter form is easier to translate to packaging manifests when building googlemock is disabled, as well as enabled, as the path remains consistent when the feature flag is disabled. Signed-off-by: Enji Cooper <yaneurabeya@gmail.com>
Diffstat (limited to 'googlemock/CMakeLists.txt')
-rw-r--r--googlemock/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
index b0c1db8..eff2a6b 100644
--- a/googlemock/CMakeLists.txt
+++ b/googlemock/CMakeLists.txt
@@ -49,7 +49,7 @@ endif()
# targets to the current scope. We are placing Google Test's binary
# directory in a subdirectory of our own as VC compilation may break
# if they are the same (the default).
-add_subdirectory("${gtest_dir}" "${gmock_BINARY_DIR}/gtest")
+add_subdirectory("${gtest_dir}" "${gmock_BINARY_DIR}/${gtest_dir}")
# These commands only run if this is the main project