summaryrefslogtreecommitdiffstats
path: root/googlemock/CMakeLists.txt
diff options
context:
space:
mode:
authorBilly Donahue <BillyDonahue@users.noreply.github.com>2015-12-10 22:25:53 (GMT)
committerBilly Donahue <BillyDonahue@users.noreply.github.com>2015-12-10 22:25:53 (GMT)
commitc1cd9c2b05d5acff704e4b831c01d2905efb0c1f (patch)
treef6903fce233fba3614de196033e406d1202bb5b6 /googlemock/CMakeLists.txt
parent57b376a9cb8b7d0efd958bfaa3204bb33a03ac5e (diff)
parent7c8ac4886a7ad513430d132c446a93c6d395345a (diff)
downloadgoogletest-c1cd9c2b05d5acff704e4b831c01d2905efb0c1f.zip
googletest-c1cd9c2b05d5acff704e4b831c01d2905efb0c1f.tar.gz
googletest-c1cd9c2b05d5acff704e4b831c01d2905efb0c1f.tar.bz2
Merge pull request #650 from jpuigcerver/master
Added missing CMake install rules for GMock
Diffstat (limited to 'googlemock/CMakeLists.txt')
-rw-r--r--googlemock/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
index cd52277..7f330c5 100644
--- a/googlemock/CMakeLists.txt
+++ b/googlemock/CMakeLists.txt
@@ -94,6 +94,14 @@ cxx_library(gmock_main
########################################################################
#
+# Install rules
+install(TARGETS gmock gmock_main
+ DESTINATION lib)
+install(DIRECTORY ${gmock_SOURCE_DIR}/include/gmock
+ DESTINATION include)
+
+########################################################################
+#
# Google Mock's own tests.
#
# You can skip this section if you aren't interested in testing