summaryrefslogtreecommitdiffstats
path: root/googletest/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@google.com>2018-02-26 09:15:50 (GMT)
committerPetr Hosek <phosek@google.com>2018-02-28 08:48:41 (GMT)
commit6baf17e9d111a444543e79e4293f75a8d5ae24c6 (patch)
treed99a92cc8abf15767a8e6366ea578074764c56e3 /googletest/CMakeLists.txt
parentfe1144246e7ecae688608f7ed0a7ec1ee3e2d2af (diff)
downloadgoogletest-6baf17e9d111a444543e79e4293f75a8d5ae24c6.zip
googletest-6baf17e9d111a444543e79e4293f75a8d5ae24c6.tar.gz
googletest-6baf17e9d111a444543e79e4293f75a8d5ae24c6.tar.bz2
Support JSON output format in addition to XML
This change allows emitting output in JSON format in addition to the already supported XML format. The implementation as well as the file structure is intentionally modelled after the XML one.
Diffstat (limited to 'googletest/CMakeLists.txt')
-rw-r--r--googletest/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
index 77b55ca..575353f 100644
--- a/googletest/CMakeLists.txt
+++ b/googletest/CMakeLists.txt
@@ -306,7 +306,9 @@ if (gtest_build_tests)
cxx_executable(gtest_xml_outfile1_test_ test gtest_main)
cxx_executable(gtest_xml_outfile2_test_ test gtest_main)
py_test(gtest_xml_outfiles_test)
+ py_test(gtest_json_outfiles_test)
cxx_executable(gtest_xml_output_unittest_ test gtest)
py_test(gtest_xml_output_unittest)
+ py_test(gtest_json_output_unittest)
endif()