summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-03-14 20:35:55 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-03-14 20:35:55 (GMT)
commitfbcc3e84c0ca87fdd528afe74bf730618d4b23e5 (patch)
tree08f75e330d0f4c52314b88fdcc48f6e43be5549e /configure.in
parent49fa4563ef21009a05c11da5e05d0e71d2c24366 (diff)
downloadhdf5-fbcc3e84c0ca87fdd528afe74bf730618d4b23e5.zip
hdf5-fbcc3e84c0ca87fdd528afe74bf730618d4b23e5.tar.gz
hdf5-fbcc3e84c0ca87fdd528afe74bf730618d4b23e5.tar.bz2
[svn-r10215] Purpose:
Configure feature Description: On some platforms with some compilers, automake's dependency tracking is silently disabled. This can be confusing for developers. Solution: Set configure to enable dependencies all the time unless the user explicitly disables them (using the configure flag --disable-dependency-tracking) or a site file overrides the default (as is the case on IRIX). Platforms tested: sleipnir, mir
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0f3b753..473d23b 100644
--- a/configure.in
+++ b/configure.in
@@ -243,6 +243,15 @@ while test -n "$hname"; do
done
dnl ----------------------------------------------------------------------
+dnl Enable dependency tracking unless the configure options or a
+dnl site-specific file told us not to. This prevents configure from
+dnl silently disabling dependencies for some compilers.
+dnl
+if test -z "${enable_dependency_tracking}"; then
+ enable_dependency_tracking="yes"
+fi
+
+dnl ----------------------------------------------------------------------
dnl Check for programs.
dnl
AC_PROG_CC