summaryrefslogtreecommitdiffstats
path: root/tools/h5copy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5copy/Makefile.am')
-rw-r--r--tools/h5copy/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/tools/h5copy/Makefile.am b/tools/h5copy/Makefile.am
index 8d1f0ac..733e5e1 100644
--- a/tools/h5copy/Makefile.am
+++ b/tools/h5copy/Makefile.am
@@ -6,7 +6,7 @@
# This file is part of HDF5. The full HDF5 copyright notice, including
# terms governing use, modification, and redistribution, is contained in
# the COPYING file, which can be found at the root of the source code
-# distribution tree, or in https://support.hdfgroup.org/ftp/HDF5/releases.
+# distribution tree, or in https://www.hdfgroup.org/licenses.
# If you do not have access to either file, you may request a copy from
# help@hdfgroup.org.
##
@@ -22,8 +22,15 @@ include $(top_srcdir)/config/commence.am
AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
# Test programs and scripts
-TEST_PROG=h5copygentest
-TEST_SCRIPT=testh5copy.sh
+if BUILD_TESTS_CONDITIONAL
+ TEST_PROG=h5copygentest
+ TEST_SCRIPT=testh5copy.sh
+# source file for the test file generator
+ h5copygentest_SOURCES=h5copygentest.c
+else
+ TEST_PROG=
+ TEST_SCRIPT=
+endif
check_SCRIPTS=$(TEST_SCRIPT)
SCRIPT_DEPEND=h5copy$(EXEEXT)
@@ -35,9 +42,6 @@ check_PROGRAMS=$(TEST_PROG)
# Add h5copy specific linker flags here
h5copy_LDFLAGS = $(LT_STATIC_EXEC) $(AM_LDFLAGS)
-# source file for the test file generator
-h5copygentest_SOURCES=h5copygentest.c
-
# All programs depend on the hdf5 and h5tools libraries
LDADD=$(LIBH5TOOLS) $(LIBHDF5)