summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Evans <jasone@canonware.com>2016-11-03 02:50:44 (GMT)
committerJason Evans <jasone@canonware.com>2016-11-03 02:50:44 (GMT)
commit83ebf2fda5603fe07fcb3ff25c0dd5ad939204d8 (patch)
treef98eabbc8d858fecff65f78ba53982368c19c129 /configure.ac
parentd82f2b3473daef45d92d2a83d11487b22f9db4d3 (diff)
downloadjemalloc-83ebf2fda5603fe07fcb3ff25c0dd5ad939204d8.zip
jemalloc-83ebf2fda5603fe07fcb3ff25c0dd5ad939204d8.tar.gz
jemalloc-83ebf2fda5603fe07fcb3ff25c0dd5ad939204d8.tar.bz2
Fix sycall(2) configure test for Linux.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6fc44c3..7df6627 100644
--- a/configure.ac
+++ b/configure.ac
@@ -379,7 +379,7 @@ case "${host}" in
AC_DEFINE([JEMALLOC_PURGE_MADVISE_FREE], [ ])
;;
*-*-linux*)
- dnl secure_getenv() is exposed by _GNU_SOURCE.
+ dnl syscall(2) and secure_getenv(3) are exposed by _GNU_SOURCE.
CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE"
abi="elf"
AC_DEFINE([JEMALLOC_HAS_ALLOCA_H])
@@ -1355,7 +1355,6 @@ dnl 10.12's deprecation warning prevents use.
SAVED_CFLAGS="${CFLAGS}"
JE_CFLAGS_APPEND([-Werror])
JE_COMPILABLE([syscall(2)], [
-#define _GNU_SOURCE
#include <sys/syscall.h>
#include <unistd.h>
], [