summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Evans <jasone@canonware.com>2016-05-04 04:28:20 (GMT)
committerJason Evans <jasone@canonware.com>2016-05-04 04:28:20 (GMT)
commitc1e9cf47f93713e9d9b7c28c13b53f90d19a2c9d (patch)
tree339f0027e6f0ab49749e8c0a6a27a04424f6c4a4 /configure.ac
parent7ba6e742335117eca1268757add9adac808e4e38 (diff)
downloadjemalloc-c1e9cf47f93713e9d9b7c28c13b53f90d19a2c9d.zip
jemalloc-c1e9cf47f93713e9d9b7c28c13b53f90d19a2c9d.tar.gz
jemalloc-c1e9cf47f93713e9d9b7c28c13b53f90d19a2c9d.tar.bz2
Link against librt for clock_gettime(2) if glibc < 2.17.
Link libjemalloc against librt if clock_gettime(2) is in librt rather than libc, as for versions of glibc prior to 2.17. This resolves #349.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 2 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 275576b..1a1c970 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1239,13 +1239,8 @@ fi
CPPFLAGS="$CPPFLAGS -D_REENTRANT"
-dnl Check whether clock_gettime(2) is in libc or librt. This function is only
-dnl used in test code, so save the result to TESTLIBS to avoid poluting LIBS.
-SAVED_LIBS="${LIBS}"
-LIBS=
-AC_SEARCH_LIBS([clock_gettime], [rt], [TESTLIBS="${LIBS}"])
-AC_SUBST([TESTLIBS])
-LIBS="${SAVED_LIBS}"
+dnl Check whether clock_gettime(2) is in libc or librt.
+AC_SEARCH_LIBS([clock_gettime], [rt])
dnl Check if the GNU-specific secure_getenv function exists.
AC_CHECK_FUNC([secure_getenv],
@@ -1751,7 +1746,6 @@ AC_MSG_RESULT([CPPFLAGS : ${CPPFLAGS}])
AC_MSG_RESULT([LDFLAGS : ${LDFLAGS}])
AC_MSG_RESULT([EXTRA_LDFLAGS : ${EXTRA_LDFLAGS}])
AC_MSG_RESULT([LIBS : ${LIBS}])
-AC_MSG_RESULT([TESTLIBS : ${TESTLIBS}])
AC_MSG_RESULT([RPATH_EXTRA : ${RPATH_EXTRA}])
AC_MSG_RESULT([])
AC_MSG_RESULT([XSLTPROC : ${XSLTPROC}])