summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Evans <jasone@canonware.com>2016-05-06 00:45:02 (GMT)
committerJason Evans <jasone@canonware.com>2016-05-06 01:56:17 (GMT)
commitc2f970c32b527660a33fa513a76d913c812dcf7c (patch)
treeb0593fac905797fa543ac77aa5ebd9e1160cb67f /configure.ac
parentdc391adc6577b4ed0dac0ce3b1778473e67e4c17 (diff)
downloadjemalloc-c2f970c32b527660a33fa513a76d913c812dcf7c.zip
jemalloc-c2f970c32b527660a33fa513a76d913c812dcf7c.tar.gz
jemalloc-c2f970c32b527660a33fa513a76d913c812dcf7c.tar.bz2
Modify pages_map() to support mapping uncommitted virtual memory.
If the OS overcommits: - Commit all mappings in pages_map() regardless of whether the caller requested committed memory. - Linux-specific: Specify MAP_NORESERVE to avoid unfortunate interactions with heuristic overcommit mode during fork(2). This resolves #193.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a1c970..7f19715 100644
--- a/configure.ac
+++ b/configure.ac
@@ -305,6 +305,7 @@ case "${host}" in
*-*-freebsd*)
CFLAGS="$CFLAGS"
abi="elf"
+ AC_DEFINE([JEMALLOC_SYSCTL_VM_OVERCOMMIT], [ ])
AC_DEFINE([JEMALLOC_PURGE_MADVISE_FREE], [ ])
force_lazy_lock="1"
;;
@@ -329,6 +330,7 @@ case "${host}" in
CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE"
abi="elf"
AC_DEFINE([JEMALLOC_HAS_ALLOCA_H])
+ AC_DEFINE([JEMALLOC_PROC_SYS_VM_OVERCOMMIT_MEMORY], [ ])
AC_DEFINE([JEMALLOC_PURGE_MADVISE_DONTNEED], [ ])
AC_DEFINE([JEMALLOC_THREADED_INIT], [ ])
AC_DEFINE([JEMALLOC_USE_CXX_THROW], [ ])