summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVincent Danjean <Vincent.Danjean@ens-lyon.org>2012-06-21 09:50:48 (GMT)
committerVincent Danjean <Vincent.Danjean@ens-lyon.org>2012-06-21 09:50:48 (GMT)
commit102237983e17a646e064aec90e2bda8c98dd8ecb (patch)
tree142ff556b0e52dad1cf131a5cd3151c197ba9bac /configure.ac
parent135d47e6c05b5771060d3b8b0b96119e6abde2d7 (diff)
downloadpatchelf-102237983e17a646e064aec90e2bda8c98dd8ecb.zip
patchelf-102237983e17a646e064aec90e2bda8c98dd8ecb.tar.gz
patchelf-102237983e17a646e064aec90e2bda8c98dd8ecb.tar.bz2
Rewrite tests in automake
- add options in AM_INIT_AUTOMAKE to be more strict and to enable more advanced features (color-tests and parallel-tests) - rewrite tests/Makefile.am to use automake rules for building program and libraries => we can now do: ./bootstrap.sh && mkdir build && cd build && ../configure && make -j distcheck
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 30ba4f9..63bf76a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
AC_INIT([patchelf], m4_esyscmd([echo -n $(cat ./version)$VERSION_SUFFIX]))
AC_CONFIG_SRCDIR([src/patchelf.cc])
AC_CONFIG_AUX_DIR([build-aux])
-AM_INIT_AUTOMAKE([dist-bzip2 foreign])
+AM_INIT_AUTOMAKE([-Wall -Werror dist-bzip2 foreign color-tests parallel-tests])
AC_PROG_CC
AC_PROG_CXX