summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-09-24 22:05:46 (GMT)
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-09-24 22:05:46 (GMT)
commitf4f4117040c3eaf0107fb431e02eefadd05d37d3 (patch)
tree899480ff84c90fa5e5d395fc273fea4fc5fcd421 /configure.ac
parent10d5f346adcae9e43401dcaf875e91541fad2f15 (diff)
downloadpatchelf-f4f4117040c3eaf0107fb431e02eefadd05d37d3.zip
patchelf-f4f4117040c3eaf0107fb431e02eefadd05d37d3.tar.gz
patchelf-f4f4117040c3eaf0107fb431e02eefadd05d37d3.tar.bz2
* Autoconfiscate patchelf.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..13a9b83
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,20 @@
+AC_INIT(patchelf, "0.1")
+AC_CONFIG_SRCDIR(patchelf.c)
+AM_INIT_AUTOMAKE
+
+# Change to `1' to produce a `stable' release (i.e., the `preREVISION'
+# suffix is not added).
+STABLE=0
+
+# Put the revision number in the version.
+if test "$STABLE" != "1"; then
+ if REVISION=`test -d $srcdir/.svn && svnversion $srcdir 2> /dev/null`; then
+ VERSION="${VERSION}pre${REVISION}"
+ elif REVISION=`cat $srcdir/svn-revision 2> /dev/null`; then
+ VERSION="${VERSION}pre${REVISION}"
+ fi
+fi
+
+AC_PROG_CC
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT