summaryrefslogtreecommitdiffstats
path: root/release.nix
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2020-06-23 12:16:37 (GMT)
committerDomen Kožar <domen@dev.si>2020-06-23 12:48:47 (GMT)
commit1e1867de901651a317244e406c057383952dd509 (patch)
tree437061a2a526ba45c42c194294778aab7c7ddd7c /release.nix
parent33daa5afcb24a1a8d5cc746de06f26d9a89bce35 (diff)
downloadpatchelf-1e1867de901651a317244e406c057383952dd509.zip
patchelf-1e1867de901651a317244e406c057383952dd509.tar.gz
patchelf-1e1867de901651a317244e406c057383952dd509.tar.bz2
CI for aarch64aarch64
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/release.nix b/release.nix
index 06bf91d..dbac5e2 100644
--- a/release.nix
+++ b/release.nix
@@ -1,6 +1,7 @@
{ patchelfSrc ? { outPath = ./.; revCount = 1234; shortRev = "abcdef"; }
, nixpkgs ? builtins.fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-20.03.tar.gz
, officialRelease ? false
+, systems ? [ "x86_64-linux" "i686-linux" "aarch64-linux" ]
}:
let
@@ -39,7 +40,7 @@ let
};
- build = pkgs.lib.genAttrs [ "x86_64-linux" "i686-linux" "aarch64-linux" /* "x86_64-freebsd" "i686-freebsd" "x86_64-darwin" "i686-solaris" "i686-cygwin" */ ] (system:
+ build = pkgs.lib.genAttrs systems (system:
with import nixpkgs { inherit system; };