summaryrefslogtreecommitdiffstats
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-11-06 14:35:16 (GMT)
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-11-06 14:35:16 (GMT)
commit2c55eab22f41c72024858521b03d492906724d7b (patch)
tree587e8781629d4d71bc3dfad6c77c48b76930ebe7 /release.nix
parent7e0f75057d7a7ca6202edea15a7aa199d70099ca (diff)
downloadpatchelf-2c55eab22f41c72024858521b03d492906724d7b.zip
patchelf-2c55eab22f41c72024858521b03d492906724d7b.tar.gz
patchelf-2c55eab22f41c72024858521b03d492906724d7b.tar.bz2
* Hydra job expression for patchelf.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/release.nix b/release.nix
new file mode 100644
index 0000000..291d0e0
--- /dev/null
+++ b/release.nix
@@ -0,0 +1,57 @@
+let jobs = rec {
+
+
+ tarball =
+ { patchelfSrc ? {path = ./.;}
+ , nixpkgs ? {path = ../nixpkgs;}
+ , release ? {path = ../release;}
+ }:
+
+ with import "${release.path}/generic-dist" nixpkgs.path;
+
+ makeSourceTarball {
+ inherit (pkgs) stdenv;
+ name = "patchelf-tarball";
+ src = patchelfSrc;
+ buildInputs = [pkgs.autoconf pkgs.automake];
+ };
+
+
+ build =
+ { tarball ? {path = jobs.tarball {};}
+ , nixpkgs ? {path = ../nixpkgs;}
+ , release ? {path = ../release;}
+ #, system ? "i686-linux"
+ }:
+
+ let system = "i686-linux"; in
+
+ with import "${release.path}/generic-dist" nixpkgs.path;
+
+ nixBuild {
+ inherit (pkgsFun {inherit system;}) stdenv;
+ name = "patchelf-build";
+ src = tarball.path;
+ };
+
+
+ rpm =
+ { tarball ? {path = jobs.tarball {};}
+ , nixpkgs ? {path = ../nixpkgs;}
+ , release ? {path = ../release;}
+ #, system ? "i686-linux"
+ }:
+
+ let system = "i686-linux"; in
+
+ with import "${release.path}/generic-dist" nixpkgs.path;
+
+ rpmBuild {
+ inherit (pkgsFun {inherit system;}) stdenv;
+ name = "patchelf-rpm";
+ src = tarball.path;
+ diskImage = diskImages_i686.fedora9i386;
+ };
+
+
+}; in jobs