summaryrefslogtreecommitdiffstats
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2019-05-08 20:14:33 (GMT)
committerEelco Dolstra <edolstra@gmail.com>2019-05-08 20:14:33 (GMT)
commit801f67a55f8d6073edc1528fce4f4a4b315c9bc3 (patch)
tree6a750863a82b0e58f395e16be7f017d335da26ce /release.nix
parente1e39f3639e39360ceebb2f7ed533cede4623070 (diff)
downloadpatchelf-801f67a55f8d6073edc1528fce4f4a4b315c9bc3.zip
patchelf-801f67a55f8d6073edc1528fce4f4a4b315c9bc3.tar.gz
patchelf-801f67a55f8d6073edc1528fce4f4a4b315c9bc3.tar.bz2
Add flake.nix
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/release.nix b/release.nix
index 55bb37b..147f3c1 100644
--- a/release.nix
+++ b/release.nix
@@ -1,10 +1,11 @@
{ patchelfSrc ? { outPath = ./.; revCount = 1234; shortRev = "abcdef"; }
+, nixpkgs ? builtins.fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-19.03.tar.gz
, officialRelease ? false
}:
let
- pkgs = import <nixpkgs> { };
+ pkgs = import nixpkgs { system = builtins.currentSystem or "x86_64-linux"; };
jobs = rec {
@@ -34,7 +35,7 @@ let
build = pkgs.lib.genAttrs [ "x86_64-linux" "i686-linux" "aarch64-linux" /* "x86_64-freebsd" "i686-freebsd" "x86_64-darwin" "i686-solaris" "i686-cygwin" */ ] (system:
- with import <nixpkgs> { inherit system; };
+ with import nixpkgs { inherit system; };
releaseTools.nixBuild {
name = "patchelf";
@@ -81,7 +82,7 @@ let
makeRPM =
system: diskImageFun:
- with import <nixpkgs> { inherit system; };
+ with import nixpkgs { inherit system; };
releaseTools.rpmBuild rec {
name = "patchelf-rpm";
@@ -97,7 +98,7 @@ let
makeDeb =
system: diskImageFun:
- with import <nixpkgs> { inherit system; };
+ with import nixpkgs { inherit system; };
releaseTools.debBuild {
name = "patchelf-deb";