summaryrefslogtreecommitdiffstats
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-11-12 16:41:52 (GMT)
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-11-12 16:41:52 (GMT)
commit9e533f3a5182dd5663f1cf5d08303f44cafe1230 (patch)
treea7b5923cad21ad88222c29ef78e0d08b0dd5990c /release.nix
parente9f9e6d4a2bc3dbe68387f14083aaca133241bb6 (diff)
downloadpatchelf-9e533f3a5182dd5663f1cf5d08303f44cafe1230.zip
patchelf-9e533f3a5182dd5663f1cf5d08303f44cafe1230.tar.gz
patchelf-9e533f3a5182dd5663f1cf5d08303f44cafe1230.tar.bz2
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix35
1 files changed, 24 insertions, 11 deletions
diff --git a/release.nix b/release.nix
index 291d0e0..7595ba6 100644
--- a/release.nix
+++ b/release.nix
@@ -13,18 +13,31 @@ let jobs = rec {
inherit (pkgs) stdenv;
name = "patchelf-tarball";
src = patchelfSrc;
- buildInputs = [pkgs.autoconf pkgs.automake];
+ buildInputs = [pkgs.autoconf pkgs.automake pkgs.pan];
};
-
- build =
+
+ coverage =
{ tarball ? {path = jobs.tarball {};}
, nixpkgs ? {path = ../nixpkgs;}
, release ? {path = ../release;}
- #, system ? "i686-linux"
}:
- let system = "i686-linux"; in
+ with import "${release.path}/generic-dist" nixpkgs.path;
+
+ coverageAnalysis {
+ inherit (pkgs) stdenv;
+ name = "patchelf-coverage";
+ src = tarball.path;
+ };
+
+
+ build =
+ { tarball ? {path = jobs.tarball {};}
+ , nixpkgs ? {path = ../nixpkgs;}
+ , release ? {path = ../release;}
+ , system ? "i686-linux"
+ }:
with import "${release.path}/generic-dist" nixpkgs.path;
@@ -32,6 +45,9 @@ let jobs = rec {
inherit (pkgsFun {inherit system;}) stdenv;
name = "patchelf-build";
src = tarball.path;
+ postInstall = ''
+ echo "doc readme $out/share/doc/patchelf/README" >> $out/nix-support/hydra-build-products
+ '';
};
@@ -39,19 +55,16 @@ let jobs = rec {
{ tarball ? {path = jobs.tarball {};}
, nixpkgs ? {path = ../nixpkgs;}
, release ? {path = ../release;}
- #, system ? "i686-linux"
}:
- let system = "i686-linux"; in
-
with import "${release.path}/generic-dist" nixpkgs.path;
rpmBuild {
- inherit (pkgsFun {inherit system;}) stdenv;
+ inherit (pkgs) stdenv;
name = "patchelf-rpm";
src = tarball.path;
diskImage = diskImages_i686.fedora9i386;
};
-
-
+
+
}; in jobs