summaryrefslogtreecommitdiffstats
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2010-03-05 17:29:59 (GMT)
committerEelco Dolstra <e.dolstra@tudelft.nl>2010-03-05 17:29:59 (GMT)
commitab8467d7e0767713d0ec2d1b26352b4e403d8087 (patch)
treeba47128373c7f41c2f8dfc936b017e212bc13de9 /release.nix
parent7742fd291b6915f84163f9888414aa52ea71fc30 (diff)
downloadpatchelf-ab8467d7e0767713d0ec2d1b26352b4e403d8087.zip
patchelf-ab8467d7e0767713d0ec2d1b26352b4e403d8087.tar.gz
patchelf-ab8467d7e0767713d0ec2d1b26352b4e403d8087.tar.bz2
* Simplify the PatchELF release expression: the `build', RPM and
Debian jobs now depend directly on the `tarball' job (i.e. as a Nix dependency, rather than indirectly through a Hydra jobset input). This ensures consistency.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix24
1 files changed, 7 insertions, 17 deletions
diff --git a/release.nix b/release.nix
index 68a038f..8222f10 100644
--- a/release.nix
+++ b/release.nix
@@ -1,4 +1,7 @@
-{nixpkgs ? ../nixpkgs}:
+{ nixpkgs ? ../nixpkgs
+, patchelfSrc ? {outPath = ./.; rev = 1234;}
+, officialRelease ? false
+}:
let
@@ -9,10 +12,6 @@ let
tarball =
- { patchelfSrc ? {outPath = ./.; rev = 1234;}
- , officialRelease ? false
- }:
-
pkgs.releaseTools.sourceTarball {
name = "patchelf-tarball";
version = builtins.readFile ./version;
@@ -26,9 +25,6 @@ let
coverage =
- { tarball ? jobs.tarball {}
- }:
-
pkgs.releaseTools.coverageAnalysis {
name = "patchelf-coverage";
src = tarball;
@@ -37,9 +33,7 @@ let
build =
- { tarball ? jobs.tarball {}
- , system ? "i686-linux"
- }:
+ { system ? "i686-linux" }:
with import nixpkgs {inherit system;};
@@ -88,14 +82,12 @@ let
makeRPM =
system: diskImageFun: prio:
- { tarball ? jobs.tarball {}
- }:
with import nixpkgs {inherit system;};
releaseTools.rpmBuild rec {
name = "patchelf-rpm";
- src = tarball;
+ src = jobs.tarball;
diskImage = diskImageFun vmTools.diskImages;
meta = { schedulingPriority = prio; };
};
@@ -106,14 +98,12 @@ let
makeDeb =
system: diskImageFun: prio:
- { tarball ? jobs.tarball {}
- }:
with import nixpkgs {inherit system;};
releaseTools.debBuild {
name = "patchelf-deb";
- src = tarball;
+ src = jobs.tarball;
diskImage = diskImageFun vmTools.diskImages;
meta = { schedulingPriority = prio; };
};