summaryrefslogtreecommitdiffstats
path: root/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-11-04 15:52:07 (GMT)
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-11-04 15:52:07 (GMT)
commite7c30c7ce9bacdc2b92bf82b1882a285adc45b0c (patch)
tree31d7185e4165f94fb972302f8199122eb41f7467 /release.nix
parentc494e83eba06734fde2f25baa656feb4921428fa (diff)
downloadpatchelf-e7c30c7ce9bacdc2b92bf82b1882a285adc45b0c.zip
patchelf-e7c30c7ce9bacdc2b92bf82b1882a285adc45b0c.tar.gz
patchelf-e7c30c7ce9bacdc2b92bf82b1882a285adc45b0c.tar.bz2
* Don't bother doing a "make check" on Darwin or Cygwin since it won't
work (they're not ELF platforms).
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index 2f2aaff..bd16e4f 100644
--- a/release.nix
+++ b/release.nix
@@ -5,7 +5,7 @@ let
pkgs = import nixpkgs {};
- jobs = rec {
+ jobs = {
tarball =
@@ -13,7 +13,7 @@ let
, officialRelease ? false
}:
- pkgs.releaseTools.makeSourceTarball {
+ pkgs.releaseTools.sourceTarball {
name = "patchelf-tarball";
version = builtins.readFile ./version;
src = patchelfSrc;
@@ -46,6 +46,7 @@ let
releaseTools.nixBuild {
name = "patchelf";
src = tarball;
+ doCheck = system != "i686-darwin" && system != "i686-cygwin";
};