summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index ecf7a9e..ec5ad19 100644
--- a/flake.nix
+++ b/flake.nix
@@ -5,15 +5,17 @@
description = "A tool for modifying ELF executables and libraries";
- requires = [ "nixpkgs" ];
+ inputs = [ "nixpkgs" ];
- provides = deps: rec {
+ outputs = inputs: rec {
hydraJobs = import ./release.nix {
- patchelfSrc = deps.self;
- nixpkgs = deps.nixpkgs;
+ patchelfSrc = inputs.self;
+ nixpkgs = inputs.nixpkgs;
};
+ checks.build = hydraJobs.build.x86_64-linux;
+
packages.patchelf = hydraJobs.build.x86_64-linux;
defaultPackage = packages.patchelf;