summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 8d570bf..e69412a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -5,6 +5,15 @@
outputs = { self, nixpkgs }: rec {
+ overlay = final: prev: {
+
+ patchelf-new = final.stdenv.mkDerivation {
+ name = "patchelf-${hydraJobs.tarball.version}";
+ src = "${hydraJobs.tarball}/tarballs/*.tar.bz2";
+ };
+
+ };
+
hydraJobs = import ./release.nix {
patchelfSrc = self;
nixpkgs = nixpkgs;
@@ -12,7 +21,10 @@
checks.build = hydraJobs.build.x86_64-linux;
- packages.patchelf = hydraJobs.build.x86_64-linux;
+ packages.patchelf = (import nixpkgs {
+ system = "x86_64-linux";
+ overlays = [ self.overlay ];
+ }).patchelf-new;
defaultPackage = packages.patchelf;