summaryrefslogtreecommitdiffstats
path: root/unix/configure.ac
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2022-06-12 15:13:33 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2022-06-12 15:13:33 (GMT)
commite396c1dd368d128a020f50ded11b388ad9bd4b4b (patch)
treef2939539f6dc1f88bb1da0d53824a281b726a6a5 /unix/configure.ac
parent82fccbc6dc66b696e8e2c0adfcfe6326bb398eea (diff)
downloadtcl-e396c1dd368d128a020f50ded11b388ad9bd4b4b.zip
tcl-e396c1dd368d128a020f50ded11b388ad9bd4b4b.tar.gz
tcl-e396c1dd368d128a020f50ded11b388ad9bd4b4b.tar.bz2
Make the idea (finally) work
Diffstat (limited to 'unix/configure.ac')
-rw-r--r--unix/configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/unix/configure.ac b/unix/configure.ac
index a1a6b17..29933bd 100644
--- a/unix/configure.ac
+++ b/unix/configure.ac
@@ -932,15 +932,11 @@ fi
# Replace ${VERSION} with contents of ${TCL_VERSION}
# double-eval to account for TCL_TRIM_DOTS.
#
-eval "TCL_STUB_LIB_FILE=libtclstub${TCL_UNSHARED_LIB_SUFFIX}"
+eval "TCL_STUB_LIB_FILE=libtclstub.a"
eval "TCL_STUB_LIB_FILE=\"${TCL_STUB_LIB_FILE}\""
eval "TCL_STUB_LIB_DIR=\"${libdir}\""
-if test "${TCL_LIB_VERSIONS_OK}" = "ok"; then
- TCL_STUB_LIB_FLAG="-ltclstub${TCL_VERSION}"
-else
- TCL_STUB_LIB_FLAG="-ltclstub`echo ${TCL_VERSION} | tr -d .`"
-fi
+TCL_STUB_LIB_FLAG="-ltclstub"
TCL_BUILD_STUB_LIB_SPEC="-L`pwd | sed -e 's/ /\\\\ /g'` ${TCL_STUB_LIB_FLAG}"
TCL_STUB_LIB_SPEC="-L${TCL_STUB_LIB_DIR} ${TCL_STUB_LIB_FLAG}"