summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2004-11-19 06:28:29 (GMT)
committerdas <das>2004-11-19 06:28:29 (GMT)
commit05b9ba728e80500b05dcfdcbd11d0d38d9ed9cd4 (patch)
tree8a7b9fc7d04eb0be39469179cd1297ff8414d356 /unix/configure.in
parent1da4df965b312f16caac077583bbe48e890b2756 (diff)
downloadtcl-05b9ba728e80500b05dcfdcbd11d0d38d9ed9cd4.zip
tcl-05b9ba728e80500b05dcfdcbd11d0d38d9ed9cd4.tar.gz
tcl-05b9ba728e80500b05dcfdcbd11d0d38d9ed9cd4.tar.bz2
* macosx/Makefile:
* unix/configure.in: * unix/tclUnixInit.c (MacOSXGetLibraryPath): changed detection of tcl framework build when determining tclLibPath from overloaded TCL_LIBRARY to configuration define TCL_FRAMEWORK. [Bug 1068088] * unix/configure: autoconf-2.57 * unix/tclConfig.h.in: autoheader-2.57
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 7d803b2..b2e8f70 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.120 2004/11/18 00:45:03 rmax Exp $
+# RCS: @(#) $Id: configure.in,v 1.121 2004/11/19 06:28:31 das Exp $
AC_INIT([tcl],[8.5])
AC_PREREQ(2.57)
@@ -497,6 +497,7 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
TCL_BUILD_LIB_SPEC="-F`pwd` -framework Tcl"
TCL_LIB_SPEC="-framework Tcl"
TCL_LIB_FILE="Tcl"
+ AC_DEFINE(TCL_FRAMEWORK, 1, [Is Tcl built as a framework?]))
elif test "$SHARED_BUILD" = "0" || test "$TCL_NEEDS_EXP_FILE" = "0"; then
if test "${TCL_LIB_VERSIONS_OK}" = "ok"; then
TCL_LIB_FLAG="-ltcl${TCL_VERSION}\${TCL_DBGX}"