summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2000-10-31 00:30:56 (GMT)
committerhobbs <hobbs>2000-10-31 00:30:56 (GMT)
commit13cdc47304c493935d7f0df35be902be6cb74176 (patch)
treee4f9c6537dcaff1c58c0580bc5737195f6a838d3 /unix/configure.in
parent58a43d42f4c70f0fd4741f184a3a4ba720f570ed (diff)
downloadtcl-13cdc47304c493935d7f0df35be902be6cb74176.zip
tcl-13cdc47304c493935d7f0df35be902be6cb74176.tar.gz
tcl-13cdc47304c493935d7f0df35be902be6cb74176.tar.bz2
* unix/configure.in (SC_TCL_LINK_LIBS): removed code that was
commented out (it had been moved to tcl.m4's SC_TCL_LINK_LIBS already).
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in65
1 files changed, 1 insertions, 64 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 9c33928..911501a 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
AC_INIT(../generic/tcl.h)
-# RCS: @(#) $Id: configure.in,v 1.62 2000/10/28 00:30:26 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.63 2000/10/31 00:30:56 hobbs Exp $
TCL_VERSION=8.4
TCL_MAJOR_VERSION=8
@@ -74,31 +74,6 @@ AC_CHECK_FUNC(uname, , [AC_DEFINE(NO_UNAME)])
AC_CHECK_FUNC(realpath, , [AC_DEFINE(NO_REALPATH)])
#--------------------------------------------------------------------
-# On a few very rare systems, all of the libm.a stuff is
-# already in libc.a. Set compiler flags accordingly.
-# Also, Linux requires the "ieee" library for math to work
-# right (and it must appear before "-lm").
-#--------------------------------------------------------------------
-
-#AC_CHECK_FUNC(sin, MATH_LIBS="", MATH_LIBS="-lm")
-#AC_CHECK_LIB(ieee, main, [MATH_LIBS="-lieee $MATH_LIBS"])
-
-#--------------------------------------------------------------------
-# On AIX systems, libbsd.a has to be linked in to support
-# non-blocking file IO. This library has to be linked in after
-# the MATH_LIBS or it breaks the pow() function. The way to
-# insure proper sequencing, is to add it to the tail of MATH_LIBS.
-# This library also supplies gettimeofday.
-#--------------------------------------------------------------------
-#libbsd=no
-#if test "`uname -s`" = "AIX" ; then
-# AC_CHECK_LIB(bsd, gettimeofday, libbsd=yes)
-# if test $libbsd = yes; then
-# MATH_LIBS="$MATH_LIBS -lbsd"
-# fi
-#fi
-
-#--------------------------------------------------------------------
# Supply substitutes for missing POSIX header files. Special
# notes:
# - stdlib.h doesn't define strtol, strtoul, or
@@ -339,14 +314,6 @@ AC_EGREP_HEADER(gettimeofday, sys/time.h, AC_MSG_RESULT(present), [
])
#--------------------------------------------------------------------
-# Interactive UNIX requires -linet instead of -lsocket, plus it
-# needs net/errno.h to define the socket-related error codes.
-#--------------------------------------------------------------------
-
-#AC_CHECK_LIB(inet, main, [LIBS="$LIBS -linet"])
-#AC_CHECK_HEADER(net/errno.h, AC_DEFINE(HAVE_NET_ERRNO_H))
-
-#--------------------------------------------------------------------
# The following code checks to see whether it is possible to get
# signed chars on this platform. This is needed in order to
# properly generate sign-extended ints from character values.
@@ -364,36 +331,6 @@ if test $tcl_ok = yes; then
fi
#--------------------------------------------------------------------
-# Check for the existence of the -lsocket and -lnsl libraries.
-# The order here is important, so that they end up in the right
-# order in the command line generated by make. Here are some
-# special considerations:
-# 1. Use "connect" and "accept" to check for -lsocket, and
-# "gethostbyname" to check for -lnsl.
-# 2. Use each function name only once: can't redo a check because
-# autoconf caches the results of the last check and won't redo it.
-# 3. Use -lnsl and -lsocket only if they supply procedures that
-# aren't already present in the normal libraries. This is because
-# IRIX 5.2 has libraries, but they aren't needed and they're
-# bogus: they goof up name resolution if used.
-# 4. On some SVR4 systems, can't use -lsocket without -lnsl too.
-# To get around this problem, check for both libraries together
-# if -lsocket doesn't work by itself.
-#--------------------------------------------------------------------
-
-#tcl_checkBoth=0
-#AC_CHECK_FUNC(connect, tcl_checkSocket=0, tcl_checkSocket=1)
-#if test "$tcl_checkSocket" = 1; then
-# AC_CHECK_LIB(socket, main, LIBS="$LIBS -lsocket", tcl_checkBoth=1)
-#fi
-#if test "$tcl_checkBoth" = 1; then
-# tk_oldLibs=$LIBS
-# LIBS="$LIBS -lsocket -lnsl"
-# AC_CHECK_FUNC(accept, tcl_checkNsl=0, [LIBS=$tk_oldLibs])
-#fi
-#AC_CHECK_FUNC(gethostbyname, , [AC_CHECK_LIB(nsl, main, [LIBS="$LIBS -lnsl"])])
-
-#--------------------------------------------------------------------
# Look for libraries that we will need when compiling the Tcl shell
#--------------------------------------------------------------------