summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2001-06-22 23:02:52 (GMT)
committermdejong <mdejong>2001-06-22 23:02:52 (GMT)
commit13d4301538ad4cf7851a755125f8f3beb21a431a (patch)
tree1d1954dbc14095b5d6971c82e8f7230cd7b6c4b5 /unix/configure.in
parentdeb831a64d0d9879e5864783eb98e054cb1dad10 (diff)
downloadtcl-13d4301538ad4cf7851a755125f8f3beb21a431a.zip
tcl-13d4301538ad4cf7851a755125f8f3beb21a431a.tar.gz
tcl-13d4301538ad4cf7851a755125f8f3beb21a431a.tar.bz2
* unix/Makefile.in: Set CFLAGS to @CFLAGS@ and @CFLAGS_DEFAULT@.
Set LDFLAGS to @LDFLAGS@ and @LDFLAGS_DEFAULT@. Add LDFLAGS_DEBUG and LDFLAGS_OPTIMIZE to match the way CFLAGS_DEFAULT works. This will support user set CFLAGS or LDFLAGS at configure time. * unix/configure: Regen. * unix/configure.in: Don't set CFLAGS to CFLAGS_DEFAULT, instead subst CFLAGS_DEFAULT into the Makefile. Add AC_SUBST for CFLAGS_DEFAULT, LDFLAGS_DEFAULT, LDFLAGS_DEBUG, and LDFLAGS_OPTIMIZE. * unix/tcl.m4 (SC_ENABLE_SYMBOLS): Modify LDFLAGS_DEFAULT so that it uses a Makefile variable just like CFLAGS_DEFAULT. * win/Makefile.in: Set CFLAGS to @CFLAGS@ and @CFLAGS_DEFAULT@. Set LDFLAGS to @LDFLAGS@ and @LDFLAGS_DEFAULT@. This will support user set CFLAGS or LDFLAGS at configure time. * win/configure: Regen. * win/configure.in: Don't set CFLAGS or LDFLAGS, instead subst CFLAGS_DEFAULT and LDFLAGS_DEFAULT into the Makefile. * win/tcl.m4 (SC_ENABLE_SYMBOLS): Modify LDFLAGS_DEFAULT so that it uses a Makefile variable just like CFLAGS_DEFAULT.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 9023e9d..1a91996 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
AC_INIT(../generic/tcl.h)
-# RCS: @(#) $Id: configure.in,v 1.66 2001/04/25 21:48:21 mdejong Exp $
+# RCS: @(#) $Id: configure.in,v 1.67 2001/06/22 23:02:53 mdejong Exp $
TCL_VERSION=8.4
TCL_MAJOR_VERSION=8
@@ -351,7 +351,6 @@ SC_CONFIG_CFLAGS
SC_ENABLE_SYMBOLS
TCL_DBGX=${DBGX}
-CFLAGS=${CFLAGS_DEFAULT}
#--------------------------------------------------------------------
# The statements below check for systems where POSIX-style
@@ -493,6 +492,7 @@ AC_SUBST(MAKE_STUB_LIB)
AC_SUBST(BUILD_DLTEST)
AC_SUBST(CFLAGS)
+AC_SUBST(CFLAGS_DEFAULT)
AC_SUBST(CFG_TCL_SHARED_LIB_SUFFIX)
AC_SUBST(CFG_TCL_UNSHARED_LIB_SUFFIX)
AC_SUBST(CFG_TCL_EXPORT_FILE_SUFFIX)
@@ -500,6 +500,10 @@ AC_SUBST(TCL_DBGX)
AC_SUBST(DL_OBJS)
AC_SUBST(EXTRA_CFLAGS)
AC_SUBST(LDFLAGS)
+AC_SUBST(LDFLAGS_DEFAULT)
+# FIXME: Should this be TCL_LDFLAGS_DEBUG ?
+AC_SUBST(LDFLAGS_DEBUG)
+AC_SUBST(LDFLAGS_OPTIMIZE)
AC_SUBST(MAKE_LIB)
AC_SUBST(TCL_SHARED_BUILD)
AC_SUBST(SHLIB_CFLAGS)