summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorvasiljevic <zv@archiware.com>2006-09-06 13:08:25 (GMT)
committervasiljevic <zv@archiware.com>2006-09-06 13:08:25 (GMT)
commit17f0d7c6ab239c4f20fb94d2f67a6e365c507143 (patch)
treeddfae99ef563e357ad94090bb150e55a7200e44d /unix/configure.in
parentd5c12918537c09220dff6836aa6ff2a1287d54d5 (diff)
downloadtcl-17f0d7c6ab239c4f20fb94d2f67a6e365c507143.zip
tcl-17f0d7c6ab239c4f20fb94d2f67a6e365c507143.tar.gz
tcl-17f0d7c6ab239c4f20fb94d2f67a6e365c507143.tar.bz2
Added MT-safe implementation of some library calls.
See Tcl Bug 999544 for more information.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in15
1 files changed, 14 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index c4dc1b3..1ea92b2 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.106.2.28 2006/07/20 06:21:45 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.106.2.29 2006/09/06 13:08:29 vasiljevic Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -142,6 +142,19 @@ if test "`uname -s`" = "Darwin" && test "${TCL_THREADS}" = 1 && \
fi
AC_CHECK_FUNC(realpath, , [AC_DEFINE(NO_REALPATH)])
+#--------------------------------------------------------------------
+# Look for thread-safe variants of some library functions.
+#--------------------------------------------------------------------
+
+if test "${TCL_THREADS}" = 1; then
+ SC_TCL_GETPWUID_R
+ SC_TCL_GETPWNAM_R
+ SC_TCL_GETGRGID_R
+ SC_TCL_GETGRNAM_R
+ SC_TCL_GETHOSTBYNAME_R
+ SC_TCL_GETHOSTBYADDR_R
+fi
+
#---------------------------------------------------------------------------
# Determine which interface to use to talk to the serial port.
# Note that #include lines must begin in leftmost column for