summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2001-11-08 03:07:19 (GMT)
committermdejong <mdejong>2001-11-08 03:07:19 (GMT)
commit24f42ede14ad162733c4f5d19806f269d217f64a (patch)
tree35af1aeff3227d5a80b4c9b0ae32d4fd2daf8fe8 /unix/configure.in
parentceb8d5b3ec54ffd8414acdfa8b799b6897e8b7d5 (diff)
downloadtcl-24f42ede14ad162733c4f5d19806f269d217f64a.zip
tcl-24f42ede14ad162733c4f5d19806f269d217f64a.tar.gz
tcl-24f42ede14ad162733c4f5d19806f269d217f64a.tar.bz2
Define TCL_INCLUDE_SPEC in tclConfig.sh. It should be
included by extensions that need to find Tcl include headers in the install location. The user can override the include install dir with --includedir so we need to record this information for extensions. [Tcl bug 421835] * unix/configure: Regen. * unix/configure.in: Define TCL_INCLUDE_SPEC. * unix/tclConfig.sh.in: Define TCL_INCLUDE_SPEC. * win/configure: Regen. * win/configure.in: Define TCL_INCLUDE_SPEC. * win/tclConfig.sh.in: Define TCL_INCLUDE_SPEC.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index aa02918..f5b2b8b 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.73 2001/10/15 21:16:31 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.74 2001/11/08 03:07:21 mdejong Exp $
AC_INIT(../generic/tcl.h)
@@ -483,6 +483,9 @@ TCL_STUB_LIB_SPEC="-L${exec_prefix}/lib ${TCL_STUB_LIB_FLAG}"
TCL_BUILD_STUB_LIB_PATH="`pwd`/${TCL_STUB_LIB_FILE}"
TCL_STUB_LIB_PATH="${exec_prefix}/lib/${TCL_STUB_LIB_FILE}"
+# Install time header dir can be set via --includedir
+eval "TCL_INCLUDE_SPEC=\"-I${includedir}\""
+
#------------------------------------------------------------------------
# tclConfig.sh refers to this by a different name
#------------------------------------------------------------------------
@@ -501,6 +504,7 @@ AC_SUBST(TCL_STUB_LIB_FILE)
AC_SUBST(TCL_STUB_LIB_FLAG)
AC_SUBST(TCL_STUB_LIB_SPEC)
AC_SUBST(TCL_STUB_LIB_PATH)
+AC_SUBST(TCL_INCLUDE_SPEC)
AC_SUBST(TCL_BUILD_STUB_LIB_SPEC)
AC_SUBST(TCL_BUILD_STUB_LIB_PATH)