summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordkf <donal.k.fellows@manchester.ac.uk>2008-12-19 10:55:38 (GMT)
committerdkf <donal.k.fellows@manchester.ac.uk>2008-12-19 10:55:38 (GMT)
commit3862cdd11b0f2223852f907fcfc52a2978987f90 (patch)
tree66c07a8c25bc46927e20f87ed8f67d2b83dd891e /unix/configure.in
parentf2070308a370f83bf12bcd7d309a3a52bbe5a6d7 (diff)
downloadtcl-3862cdd11b0f2223852f907fcfc52a2978987f90.zip
tcl-3862cdd11b0f2223852f907fcfc52a2978987f90.tar.gz
tcl-3862cdd11b0f2223852f907fcfc52a2978987f90.tar.bz2
More autoconf hacking; now seems to be working fully on Unix...
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in13
1 files changed, 5 insertions, 8 deletions
diff --git a/unix/configure.in b/unix/configure.in
index c09a5ad..bc2a97c 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.199 2008/12/19 03:54:44 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.200 2008/12/19 10:55:38 dkf Exp $
AC_INIT([tcl],[8.6])
AC_PREREQ(2.59)
@@ -129,9 +129,10 @@ AS_IF([test $zlib_ok = yes], [
AC_MSG_WARN([todo: Add compat/zlib to list of things to build])
])])
AS_IF([test $zlib_ok = no], [
- AC_SUBST(ZLIB_DIR,[\${TOP_DIR}/compat/zlib/])
- AC_SUBST(ZLIB_LIB,[libz.a])
- CFLAGS="$CFLAGS -I\${ZLIB_DIR}"
+ AC_SUBST(ZLIB_DIR,[\${COMPAT_DIR}/zlib])
+ AC_SUBST(ZLIB_OBJS,[\${ZLIB_OBJS}])
+ AC_SUBST(ZLIB_SRCS,[\${ZLIB_SRCS}])
+ AC_SUBST(ZLIB_INCLUDE,[-I\${ZLIB_DIR}])
])
AC_DEFINE(HAVE_ZLIB, 1, [Is there an installed zlib?])
@@ -844,10 +845,6 @@ TCL_STUB_LIB_PATH="${TCL_STUB_LIB_DIR}/${TCL_STUB_LIB_FILE}"
# Install time header dir can be set via --includedir
eval "TCL_INCLUDE_SPEC=\"-I${includedir}\""
-AS_IF([test $zlib_ok = no], [
- LD_SEARCH_FLAGS="\${ZLIB_LIBRARY} ${LD_SEARCH_FLAGS}"
-])
-
#------------------------------------------------------------------------
# tclConfig.sh refers to this by a different name
#------------------------------------------------------------------------