summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2007-04-29 02:20:36 (GMT)
committerdas <das>2007-04-29 02:20:36 (GMT)
commit3d880fffc971a2ee2d80081689bbafd1c4b8544e (patch)
tree6affa180f9142411ad4fcd8ce5158ce7b6e8e6b6 /unix/configure.in
parentd35f5919310fc5689bf42d63db9fde494768cb70 (diff)
downloadtcl-3d880fffc971a2ee2d80081689bbafd1c4b8544e.zip
tcl-3d880fffc971a2ee2d80081689bbafd1c4b8544e.tar.gz
tcl-3d880fffc971a2ee2d80081689bbafd1c4b8544e.tar.bz2
* unix/Makefile.in (dist): copy license.terms to dist macosx dir.
* unix/configure.in: install license.terms into Tcl.framework. * unix/configure: autoconf-2.13
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 149a84d..8d7dc2f 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.106.2.34 2007/02/04 02:51:37 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.106.2.35 2007/04/29 02:20:38 das Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -589,6 +589,7 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
EXTRA_INSTALL="install-private-headers html-tcl"
EXTRA_BUILD_HTML='@ln -fs contents.htm $(HTML_INSTALL_DIR)/TclTOC.html'
EXTRA_INSTALL_BINARIES='@echo "Installing Info.plist to $(LIB_INSTALL_DIR)/Resources" && mkdir -p "$(LIB_INSTALL_DIR)/Resources" && $(INSTALL_DATA) Tcl-Info.plist "$(LIB_INSTALL_DIR)/Resources/Info.plist"'
+ EXTRA_INSTALL_BINARIES="$EXTRA_INSTALL_BINARIES"' && echo "Installing license.terms to $(LIB_INSTALL_DIR)/Resources" && $(INSTALL_DATA) "$(TOP_DIR)/license.terms" "$(LIB_INSTALL_DIR)/Resources"'
EXTRA_INSTALL_BINARIES="$EXTRA_INSTALL_BINARIES"' && echo "Finalizing Tcl.framework" && rm -f "$(LIB_INSTALL_DIR)/../Current" && ln -s "$(VERSION)" "$(LIB_INSTALL_DIR)/../Current" && for f in "$(LIB_FILE)" tclConfig.sh Resources Headers PrivateHeaders; do rm -f "$(LIB_INSTALL_DIR)/../../$$f" && ln -s "Versions/Current/$$f" "$(LIB_INSTALL_DIR)/../.."; done && f="$(STUB_LIB_FILE)" && rm -f "$(LIB_INSTALL_DIR)/../../$$f" && ln -s "Versions/$(VERSION)/$$f" "$(LIB_INSTALL_DIR)/../.."'
TCL_YEAR="`date +%Y`"
# Don't use AC_DEFINE for the following as the framework version define